Phone number: (315) 930-4535
Email: sales@buyitsolutions.com
Address: 241-40 86th Rd Jamaica New York 11426 United States
EIN NUMBER: 93-2319428
D-U-N-S Number: 130972525
Skip to product information
Trendnet
Trendnet TI-PG541i Managed L2+ Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) Black
SKU:
TI-PG541I
Condition: New
$340.61 USD
Pickup currently not available
✔
Factory-Sealed
Sourced from authorized distributors
✔
Manufacturer Warranty
Terms set by the brand
✔
Enterprise Expertise
Business Procurement
Free standard shipping over $2,500
Delivery estimates are based on product availability, destination, fulfillment method, and qualifying order requirements. 30-day returns; 20% restocking fee on non-defective returns. Shipping policy · Return policy
Loading documents...
Need Help Before You Order?
Check compatibility, availability, or volume pricing with an IT procurement specialist.
Enterprise IT Procurement Built for Business
Source servers, networking, storage, workstations, and business technology through established distribution channels with dedicated procurement support.
1,700+
Business Accounts Supported
32,000+
Enterprise Hardware Products Available
Fast, Reliable Procurement Support
Reach out for responsive product availability, part numbers, pricing, and additional hardware needs.
4–8 Hrs
Typical RFQ Response Target
Multi-Vendor
Hardware Sourcing
Keep Your IT Projects Moving
For business hardware purchases and larger deployments, get shipment information, order coordination, and delivery support.
Manufacturer Warranty Coverage
Eligible products include warranty coverage provided by the original manufacturer according to applicable brand and product terms.
Brand Warranty TermsFactory-Sealed HardwareOEM Support Eligibility
A Trusted Source for Enterprise Hardware
Source factory-sealed IT hardware through established technology distribution channels, with support for individual purchases, BOM requests, and larger business requirements.
112+
Technology Brands
32,000+
Hardware Products Available
Key Features
6-Port Hardened Industrial Gigabit PoE+ Layer 2 Managed DIN-Rail Switch
Industrial Hardened Design
Equipped with a rugged IP30 rated enclosure and designed to withstand a high degree of vibration, shock, protection against ESD/EMI/surge, and operate with a wide temperature range (- 40 – 70 °C (- 40 - 158 °F)) for harsh environments.
Integration Flexibility
Managed features include PoE per port control/priority/scheduling/power delay, 802.1Q/MAC-based VLAN, IGMP snooping, per port bandwidth control/802.1p/DSCP/queue scheduling, and SNMP trap/RMON/SMTP alert/syslog/port mirror for monitoring and flexible network integration.
Fault Tolerance
Features dual redundant power inputs (Primary and RPS) from external power sources and an output alarm relay to indicate the event of input power failure
Full PoE+ Power Budget
Supplies up to 30 Watts of PoE/PoE+ power per port (ports 1-4 802.3at/802.3af) with a 120 Watt PoE power budget
Network Ports and Capacity
4 x Gigabit PoE+ ports, 1 x Gigabit Port, and 1 x Gigabit SFP slot allow for a 12Gbps switching capacity
Integrated DIN-Rail Mount
IP30 rated metal enclosure with integrated DIN-rail mounting hardware
Full PoE Control Per Port
PoE control features include enabling/disabling PoE and class, power priority, PD alive check, scheduling, and power delay per port using CLI or web management.
L2 Management
Managed features include 802.1Q, /MAC-Based VLAN, IGMP v1/2/3 Snooping, per port bandwidth control/802.1p/DSCP/Queue Scheduling (SP/WFQ/WRR), and Storm Control for flexible network integration.
System Monitoring
Monitoring features include SNMPv1/v2c, MIB support, SNMP trap, RMON Groups (1, 2, 3, 9), SMTP alert, syslog, and port mirroring.
Redundant Power
Dual redundant power inputs (primary and RPS) with overload current protection
Alarm Output
Alarm relay output triggered by power failure of primary and/or redundant power (DIP switch)
Jumbo Frame
Sends larger packets, or Jumbo Frames (up to 10K)
Wide Temperature
Hardened switch is rated for an operating temperature range of - 40 to 70 °C (-40 to 158 °F)
Electro Magnetic Compliance
Complies with IEC61000-6-2 EMC generic standard immunity for industrial environments
Shock and Vibration Resistant
Rated for shock (IEC 60068-2-27), freefall (IEC 60068-2-32), and vibration (IEC 60068-2-6)
LED Indicators
LED indicators convey power, redundant power, alarm, SFP, PoE, and network port status
Grounding Point
Grounding point protects equipment from external electrical surges
Key Features
- Hardened IP30 rated metal enclosure with integrated DIN-Rail mount
- Wide operating temperature range - 40 to 70 °C (-40 to 158 °F)
- 4 x Gigabit PoE+ (802.3at) ports, 1 x Gigabit port, and 1 x Gigabit SFP slot
- 120 Watts total power budget
- Redundant power inputs and alarm relay output
- CLI (Telnet), Web (HTTP), SNMP v1 / v2c management
- 802.1Q / MAC-Based VLAN and IGMP Snooping support
- 802.1p / DSCP / Queue Scheduling (SP/WFQ/WRR) QoS support
- Supports Ethernet Ring Protection Switching (ERPsv2)
- NDAA / TAA compliant
Description
TRENDnet’s 6-Port Hardened Industrial Gigabit PoE+ Layer 2 Managed DIN-Rail Switch, model TI-PG541i, has four Gigabit PoE+ ports, one Gigabit port, one Gigabit SFP slot and a 120 Watts PoE budget. The switch is equipped with an IP30 rated metal enclosure and designed to withstand a high degree of vibration, shock, protection against ESD/EMI/surge, and operate within a wide temperature range (- 40 – 70 °C (- 40 - 158 °F)) for harsh environments. L2 management include features such as PoE port control, VLAN, multicast, and QoS which allow for network integration flexibility.Industrial Hardened Design
Equipped with a rugged IP30 rated enclosure and designed to withstand a high degree of vibration, shock, protection against ESD/EMI/surge, and operate with a wide temperature range (- 40 – 70 °C (- 40 - 158 °F)) for harsh environments.
Integration Flexibility
Managed features include PoE per port control/priority/scheduling/power delay, 802.1Q/MAC-based VLAN, IGMP snooping, per port bandwidth control/802.1p/DSCP/queue scheduling, and SNMP trap/RMON/SMTP alert/syslog/port mirror for monitoring and flexible network integration.
Fault Tolerance
Features dual redundant power inputs (Primary and RPS) from external power sources and an output alarm relay to indicate the event of input power failure
Full PoE+ Power Budget
Supplies up to 30 Watts of PoE/PoE+ power per port (ports 1-4 802.3at/802.3af) with a 120 Watt PoE power budget
Network Ports and Capacity
4 x Gigabit PoE+ ports, 1 x Gigabit Port, and 1 x Gigabit SFP slot allow for a 12Gbps switching capacity
Integrated DIN-Rail Mount
IP30 rated metal enclosure with integrated DIN-rail mounting hardware
Full PoE Control Per Port
PoE control features include enabling/disabling PoE and class, power priority, PD alive check, scheduling, and power delay per port using CLI or web management.
L2 Management
Managed features include 802.1Q, /MAC-Based VLAN, IGMP v1/2/3 Snooping, per port bandwidth control/802.1p/DSCP/Queue Scheduling (SP/WFQ/WRR), and Storm Control for flexible network integration.
System Monitoring
Monitoring features include SNMPv1/v2c, MIB support, SNMP trap, RMON Groups (1, 2, 3, 9), SMTP alert, syslog, and port mirroring.
Redundant Power
Dual redundant power inputs (primary and RPS) with overload current protection
Alarm Output
Alarm relay output triggered by power failure of primary and/or redundant power (DIP switch)
Jumbo Frame
Sends larger packets, or Jumbo Frames (up to 10K)
Wide Temperature
Hardened switch is rated for an operating temperature range of - 40 to 70 °C (-40 to 158 °F)
Electro Magnetic Compliance
Complies with IEC61000-6-2 EMC generic standard immunity for industrial environments
Shock and Vibration Resistant
Rated for shock (IEC 60068-2-27), freefall (IEC 60068-2-32), and vibration (IEC 60068-2-6)
LED Indicators
LED indicators convey power, redundant power, alarm, SFP, PoE, and network port status
Grounding Point
Grounding point protects equipment from external electrical surges
Specifications
| Management features | |
|---|---|
| ARP inspection | Yes |
| Switch type | Managed |
| Web-based management | Yes |
| System event log | Yes |
| Quality of Service (QoS) support | Yes |
| Multicast support | Yes |
| MIB support | RFC 1213, RFC 1493, RFC 1643, RFC 1757 |
| Switch layer | L2+ |
| Ports & interfaces | |
| SFP module slots quantity | 1 |
| Basic switching RJ-45 Ethernet ports quantity | 5 |
| Basic switching RJ-45 Ethernet ports type | Gigabit Ethernet (10/100/1000) |
| Installed SFP modules quantity | 0 |
| Installed SFP+ modules quantity | 0 |
| Terminal block port | Yes |
| Network | |
| MAC address auto-learning supported | Yes |
| Networking standards | IEEE 802.1D, IEEE 802.1Q, IEEE 802.1ab, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.3, IEEE 802.3ab, IEEE 802.3ad, IEEE 802.3at, IEEE 802.3u, IEEE 802.3x |
| Full duplex | Yes |
| VLAN support | Yes |
| Port mirroring | Yes |
| Number of VLANs | 256 |
| Link aggregation | Yes |
| Broadcast storm control | Yes |
| 10G support | No |
| Virtual LAN features | Tagged VLAN, Protocol-based VLAN |
| IGMP snooping | Yes |
| Data transmission | |
| Jumbo frames | 10000 |
| Throughput | 8.93 Mpps |
| Packet buffer memory | 128 MB |
| MAC address table | 16000 entries |
| Switching capacity | 12 Gbit/s |
| Jumbo frames support | Yes |
| Multicast MAC address table | 256 entries |
| Number of VLANs | 256 |
| Security | |
| Loop protection | Yes |
| Authentication | Port-based authentication |
| Security algorithms | 802.1x RADIUS, HTTPS, SNMP |
| IGMP snooping | Yes |
| Access Control List (ACL) | Yes |
| DHCP features | DHCP server |
| Multicast features | |
| Multicast MAC address table | 256 entries |
| Multicast support | Yes |
| Design | |
| International Protection (IP) code | IP30 |
| DIN rail mounting | Yes |
| Product colour | Black |
| LED indicators | Yes |
| Rack mounting | No |
| Performance | |
| Mean time between failures (MTBF) | 435905 h |
| Packet buffer memory | 128 MB |
| Harmonized System (HS) code | 85176990 |
| Power | |
| Power consumption (max) | 130 W |
| Output voltage | 48 V |
| Output current | 5 A |
| AC input voltage | 100 - 240 V |
| AC input frequency | 50 - 60 Hz |
| Redundant power supply (RPS) support | Yes |
| Power over Ethernet (PoE) | |
| Power over Ethernet (PoE) power per port | 30 W |
| Power over Ethernet plus (PoE+) ports quantity | 4 |
| Total Power over Ethernet (PoE) budget | 120 W |
| Power over Ethernet (PoE) | Yes |
| Other features | |
| Terminal block port | Yes |
| Operational conditions | |
| Operating temperature (T-T) | -40 - 70 °C |
| Operating relative humidity (H-H) | 0 - 95% |
| Virtual LAN features | |
| VLAN support | Yes |
| Number of VLANs | 256 |
| Virtual LAN features | Tagged VLAN, Protocol-based VLAN |
| Weight & dimensions | |
| Width | 5.31" (135 mm) |
| Depth | 4.72" (120 mm) |
| Height | 1.22" (31 mm) |
| Weight | 18.6 oz (528 g) |
| Packaging content | |
| Quick start guide | Yes |
| Terminal block included | Yes |
| Resource CD | Yes |
| Packaging data | |
| Terminal block included | Yes |
| Package type | Box |
| Resource CD | Yes |
| Quick start guide | Yes |
| Technical details | |
| Product colour | Black |
| Mean time between failures (MTBF) | 435905 h |
| Rack mounting | No |
| Memory | |
| Packet buffer memory | 128 MB |
| Indication | |
| LED indicators | Yes |
| Logistics data | |
| Harmonized System (HS) code | 85176990 |
Product Specs
6-Port Hardened Industrial Gigabit PoE+ Layer 2 Managed DIN-Rail Switch
Industrial Hardened Design
Equipped with a rugged IP30 rated enclosure and designed to withstand a high degree of vibration, shock, protection against ESD/EMI/surge, and operate with a wide temperature range (- 40 – 70 °C (- 40 - 158 °F)) for harsh environments.
Integration Flexibility
Managed features include PoE per port control/priority/scheduling/power delay, 802.1Q/MAC-based VLAN, IGMP snooping, per port bandwidth control/802.1p/DSCP/queue scheduling, and SNMP trap/RMON/SMTP alert/syslog/port mirror for monitoring and flexible network integration.
Fault Tolerance
Features dual redundant power inputs (Primary and RPS) from external power sources and an output alarm relay to indicate the event of input power failure
Full PoE+ Power Budget
Supplies up to 30 Watts of PoE/PoE+ power per port (ports 1-4 802.3at/802.3af) with a 120 Watt PoE power budget
Network Ports and Capacity
4 x Gigabit PoE+ ports, 1 x Gigabit Port, and 1 x Gigabit SFP slot allow for a 12Gbps switching capacity
Integrated DIN-Rail Mount
IP30 rated metal enclosure with integrated DIN-rail mounting hardware
Full PoE Control Per Port
PoE control features include enabling/disabling PoE and class, power priority, PD alive check, scheduling, and power delay per port using CLI or web management.
L2 Management
Managed features include 802.1Q, /MAC-Based VLAN, IGMP v1/2/3 Snooping, per port bandwidth control/802.1p/DSCP/Queue Scheduling (SP/WFQ/WRR), and Storm Control for flexible network integration.
System Monitoring
Monitoring features include SNMPv1/v2c, MIB support, SNMP trap, RMON Groups (1, 2, 3, 9), SMTP alert, syslog, and port mirroring.
Redundant Power
Dual redundant power inputs (primary and RPS) with overload current protection
Alarm Output
Alarm relay output triggered by power failure of primary and/or redundant power (DIP switch)
Jumbo Frame
Sends larger packets, or Jumbo Frames (up to 10K)
Wide Temperature
Hardened switch is rated for an operating temperature range of - 40 to 70 °C (-40 to 158 °F)
Electro Magnetic Compliance
Complies with IEC61000-6-2 EMC generic standard immunity for industrial environments
Shock and Vibration Resistant
Rated for shock (IEC 60068-2-27), freefall (IEC 60068-2-32), and vibration (IEC 60068-2-6)
LED Indicators
LED indicators convey power, redundant power, alarm, SFP, PoE, and network port status
Grounding Point
Grounding point protects equipment from external electrical surges
Key Features
- Hardened IP30 rated metal enclosure with integrated DIN-Rail mount
- Wide operating temperature range - 40 to 70 °C (-40 to 158 °F)
- 4 x Gigabit PoE+ (802.3at) ports, 1 x Gigabit port, and 1 x Gigabit SFP slot
- 120 Watts total power budget
- Redundant power inputs and alarm relay output
- CLI (Telnet), Web (HTTP), SNMP v1 / v2c management
- 802.1Q / MAC-Based VLAN and IGMP Snooping support
- 802.1p / DSCP / Queue Scheduling (SP/WFQ/WRR) QoS support
- Supports Ethernet Ring Protection Switching (ERPsv2)
- NDAA / TAA compliant
Description
TRENDnet’s 6-Port Hardened Industrial Gigabit PoE+ Layer 2 Managed DIN-Rail Switch, model TI-PG541i, has four Gigabit PoE+ ports, one Gigabit port, one Gigabit SFP slot and a 120 Watts PoE budget. The switch is equipped with an IP30 rated metal enclosure and designed to withstand a high degree of vibration, shock, protection against ESD/EMI/surge, and operate within a wide temperature range (- 40 – 70 °C (- 40 - 158 °F)) for harsh environments. L2 management include features such as PoE port control, VLAN, multicast, and QoS which allow for network integration flexibility.Industrial Hardened Design
Equipped with a rugged IP30 rated enclosure and designed to withstand a high degree of vibration, shock, protection against ESD/EMI/surge, and operate with a wide temperature range (- 40 – 70 °C (- 40 - 158 °F)) for harsh environments.
Integration Flexibility
Managed features include PoE per port control/priority/scheduling/power delay, 802.1Q/MAC-based VLAN, IGMP snooping, per port bandwidth control/802.1p/DSCP/queue scheduling, and SNMP trap/RMON/SMTP alert/syslog/port mirror for monitoring and flexible network integration.
Fault Tolerance
Features dual redundant power inputs (Primary and RPS) from external power sources and an output alarm relay to indicate the event of input power failure
Full PoE+ Power Budget
Supplies up to 30 Watts of PoE/PoE+ power per port (ports 1-4 802.3at/802.3af) with a 120 Watt PoE power budget
Network Ports and Capacity
4 x Gigabit PoE+ ports, 1 x Gigabit Port, and 1 x Gigabit SFP slot allow for a 12Gbps switching capacity
Integrated DIN-Rail Mount
IP30 rated metal enclosure with integrated DIN-rail mounting hardware
Full PoE Control Per Port
PoE control features include enabling/disabling PoE and class, power priority, PD alive check, scheduling, and power delay per port using CLI or web management.
L2 Management
Managed features include 802.1Q, /MAC-Based VLAN, IGMP v1/2/3 Snooping, per port bandwidth control/802.1p/DSCP/Queue Scheduling (SP/WFQ/WRR), and Storm Control for flexible network integration.
System Monitoring
Monitoring features include SNMPv1/v2c, MIB support, SNMP trap, RMON Groups (1, 2, 3, 9), SMTP alert, syslog, and port mirroring.
Redundant Power
Dual redundant power inputs (primary and RPS) with overload current protection
Alarm Output
Alarm relay output triggered by power failure of primary and/or redundant power (DIP switch)
Jumbo Frame
Sends larger packets, or Jumbo Frames (up to 10K)
Wide Temperature
Hardened switch is rated for an operating temperature range of - 40 to 70 °C (-40 to 158 °F)
Electro Magnetic Compliance
Complies with IEC61000-6-2 EMC generic standard immunity for industrial environments
Shock and Vibration Resistant
Rated for shock (IEC 60068-2-27), freefall (IEC 60068-2-32), and vibration (IEC 60068-2-6)
LED Indicators
LED indicators convey power, redundant power, alarm, SFP, PoE, and network port status
Grounding Point
Grounding point protects equipment from external electrical surges
Specifications
| Management features | |
|---|---|
| ARP inspection | Yes |
| Switch type | Managed |
| Web-based management | Yes |
| System event log | Yes |
| Quality of Service (QoS) support | Yes |
| Multicast support | Yes |
| MIB support | RFC 1213, RFC 1493, RFC 1643, RFC 1757 |
| Switch layer | L2+ |
| Ports & interfaces | |
| SFP module slots quantity | 1 |
| Basic switching RJ-45 Ethernet ports quantity | 5 |
| Basic switching RJ-45 Ethernet ports type | Gigabit Ethernet (10/100/1000) |
| Installed SFP modules quantity | 0 |
| Installed SFP+ modules quantity | 0 |
| Terminal block port | Yes |
| Network | |
| MAC address auto-learning supported | Yes |
| Networking standards | IEEE 802.1D, IEEE 802.1Q, IEEE 802.1ab, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.3, IEEE 802.3ab, IEEE 802.3ad, IEEE 802.3at, IEEE 802.3u, IEEE 802.3x |
| Full duplex | Yes |
| VLAN support | Yes |
| Port mirroring | Yes |
| Number of VLANs | 256 |
| Link aggregation | Yes |
| Broadcast storm control | Yes |
| 10G support | No |
| Virtual LAN features | Tagged VLAN, Protocol-based VLAN |
| IGMP snooping | Yes |
| Data transmission | |
| Jumbo frames | 10000 |
| Throughput | 8.93 Mpps |
| Packet buffer memory | 128 MB |
| MAC address table | 16000 entries |
| Switching capacity | 12 Gbit/s |
| Jumbo frames support | Yes |
| Multicast MAC address table | 256 entries |
| Number of VLANs | 256 |
| Security | |
| Loop protection | Yes |
| Authentication | Port-based authentication |
| Security algorithms | 802.1x RADIUS, HTTPS, SNMP |
| IGMP snooping | Yes |
| Access Control List (ACL) | Yes |
| DHCP features | DHCP server |
| Multicast features | |
| Multicast MAC address table | 256 entries |
| Multicast support | Yes |
| Design | |
| International Protection (IP) code | IP30 |
| DIN rail mounting | Yes |
| Product colour | Black |
| LED indicators | Yes |
| Rack mounting | No |
| Performance | |
| Mean time between failures (MTBF) | 435905 h |
| Packet buffer memory | 128 MB |
| Harmonized System (HS) code | 85176990 |
| Power | |
| Power consumption (max) | 130 W |
| Output voltage | 48 V |
| Output current | 5 A |
| AC input voltage | 100 - 240 V |
| AC input frequency | 50 - 60 Hz |
| Redundant power supply (RPS) support | Yes |
| Power over Ethernet (PoE) | |
| Power over Ethernet (PoE) power per port | 30 W |
| Power over Ethernet plus (PoE+) ports quantity | 4 |
| Total Power over Ethernet (PoE) budget | 120 W |
| Power over Ethernet (PoE) | Yes |
| Other features | |
| Terminal block port | Yes |
| Operational conditions | |
| Operating temperature (T-T) | -40 - 70 °C |
| Operating relative humidity (H-H) | 0 - 95% |
| Virtual LAN features | |
| VLAN support | Yes |
| Number of VLANs | 256 |
| Virtual LAN features | Tagged VLAN, Protocol-based VLAN |
| Weight & dimensions | |
| Width | 5.31" (135 mm) |
| Depth | 4.72" (120 mm) |
| Height | 1.22" (31 mm) |
| Weight | 18.6 oz (528 g) |
| Packaging content | |
| Quick start guide | Yes |
| Terminal block included | Yes |
| Resource CD | Yes |
| Packaging data | |
| Terminal block included | Yes |
| Package type | Box |
| Resource CD | Yes |
| Quick start guide | Yes |
| Technical details | |
| Product colour | Black |
| Mean time between failures (MTBF) | 435905 h |
| Rack mounting | No |
| Memory | |
| Packet buffer memory | 128 MB |
| Indication | |
| LED indicators | Yes |
| Logistics data | |
| Harmonized System (HS) code | 85176990 |
Loading product information from Icecat...
Related products
FAQ
Questions? We're Here to Help.
Can't find what you're looking for? Our team is available through live chat.
Need immediate assistance?
Our sales engineering and accounts team is available Monday through Friday, 9:00 AM to 6:00 PM ET.
Call (315) 930-4535We offer computing hardware, networking equipment, servers and storage, plus power and security products from leading technology brands.
Yes, our team provides pre-sale consultation and post-purchase support to ensure you get the right solutions for your needs.
Return new, undamaged items with all accessories and original packaging within 30 days of delivery. A 20% restocking fee applies to non-defective returns. Defective, damaged or incorrect items are replaced or refunded, with a free return label.
Standard shipping is $25, free on orders over $2,500 in the contiguous US Express is $40, or $350 on orders over $2,500. Alaska and Hawaii ship by air for $85. In-stock orders leave the warehouse within 2-3 business days, standard transit is 5-7 business days and express 1–2 days.
Absolutely! Contact our sales team via live chat, phone, or email to discuss your requirements and receive a customized quote.
Popular Queries
LG 50UL3Q-E signage display Digital signage flat panel 50" LED Wi-Fi 350 cd/m² 4K Ultra HD Black WebOS 16/7
DELL Pro 65 Plus P6524QT Interactive flat panel 64.53" LCD 350 cd/m² 4K Ultra HD Black Touchscreen
LG 65UL3Q-E signage display Digital signage flat panel 65" LED Wi-Fi 350 cd/m² 4K Ultra HD Black WebOS 16/7
APC Replacement Battery Cartridge, VRLA battery, 10Ah, 48VDC, 2-year warranty
Lind Electronics GE1950I-4157 power adapter/inverter Auto Black
Logitech Tap Scheduler 2 video conferencing system Ethernet LAN Video conferencing service management system
HP Poly Savi 7310-M Office Microsoft Teams Certified DECT 1920-1930 MHz Headset TAA
Juniper EX4100-24T network switch Unmanaged Power over Ethernet (PoE) 1U Gray
NETGEAR GSM4352PB Managed L2/L3/L4 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) 1U Black
HPE Aruba Networking CX 6200F 24G Class-4 PoE 4SFP+ 370W Managed L3 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) 1U
Ubiquiti USW-Pro-Max-24-PoE L3 2.5G Ethernet (100/1000/2500) Power over Ethernet (PoE) Gray
HP Poly Trio C60 IP Conference Phone Full Radio and PoE-enabled GSA/TAA
AddOn Networks QSFP28-100GB-SR4-E-AR-AO network transceiver module Fiber optic 100000 Mbit/s 850 nm
Axiom Q28-100G-BIDI-DLN-AX network transceiver module Fiber optic 100000 Mbit/s QSFP28
HP Poly TC10 White Touch Controller
View all →