Phone number: (315) 930-4535
Email: sales@buyitsolutions.com
Address: 241-40 86th Rd Jamaica New York 11426 United States
EIN NUMBER: 93-2319428
D-U-N-S Number: 130972525
Skip to product information
Trendnet
Trendnet TPE-5028WS network switch Managed Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) 1U Black
SKU:
TPE-5028WS
Condition: New
$547.39 USD
Pickup currently not available
✔
Factory-Sealed
Sourced from authorized distributors
✔
Manufacturer Warranty
Terms set by the brand
✔
Enterprise Expertise
Business Procurement
Free standard shipping over $2,500
Delivery estimates are based on product availability, destination, fulfillment method, and qualifying order requirements. 30-day returns; 20% restocking fee on non-defective returns. Shipping policy · Return policy
Loading documents...
Need Help Before You Order?
Check compatibility, availability, or volume pricing with an IT procurement specialist.
Enterprise IT Procurement Built for Business
Source servers, networking, storage, workstations, and business technology through established distribution channels with dedicated procurement support.
1,700+
Business Accounts Supported
32,000+
Enterprise Hardware Products Available
Fast, Reliable Procurement Support
Reach out for responsive product availability, part numbers, pricing, and additional hardware needs.
4–8 Hrs
Typical RFQ Response Target
Multi-Vendor
Hardware Sourcing
Keep Your IT Projects Moving
For business hardware purchases and larger deployments, get shipment information, order coordination, and delivery support.
Manufacturer Warranty Coverage
Eligible products include warranty coverage provided by the original manufacturer according to applicable brand and product terms.
Brand Warranty TermsFactory-Sealed HardwareOEM Support Eligibility
A Trusted Source for Enterprise Hardware
Source factory-sealed IT hardware through established technology distribution channels, with support for individual purchases, BOM requests, and larger business requirements.
112+
Technology Brands
32,000+
Hardware Products Available
Key Features
24 x Gigabit PoE+ ports, 4 x Shared Gigabit ports, 370 W, 56 Gbps
Web Smart Management
Provides an easy-to-use web-based management interface to reduce switch configuration complexity and offers a combination of SMB management features for easy deployment.
Integration Flexibility
Managed features include access control lists, VLAN, IGMP snooping, QoS, RMON, SNMP trap, and syslog for monitoring and flexible network integration.
PoE Power
A 370W PoE power budget supplies power to PoE/PoE+ devices.
Hardware Design
Provides 24 gigabit PoE+ ports, 4 shared gigabit ports (RJ-45 or SFP), a 56Gbps switching capacity, a built-in power supply, and rackmount brackets.
PoE Power
Supports up to 30W of PoE+ power per port with a total power budget of 370W.
IPv6 Ready
This switch supports IPv6 configuration and IPv6 neighbor discovery.
Traffic Management
A broad range of network configurations are supported: 802.3ad link aggregation, Asymmetric VLAN, 802.1Q VLAN, Voice VLAN, RSTP, MSTP, Loopback Detection, GVRP, 802.1p Class of Service (CoS), port bandwidth management, and QoS queue scheduling.
Troubleshooting
A convenient cable diagnostic test and traffic statistics aid in network troubleshooting
Access Control
Features such as ACL, SSL, MAC/port filtering, 802.1X, TACACS+, and RADIUS are compatible with layered access controls.
Monitoring
RMON, SNMP, SNMP Trap, and Port Mirroring support administrator monitoring solutions.
Key Features
- 24 x Gigabit PoE+ ports
- 4 x Shared Gigabit ports (RJ-45 or SFP)
- 370W PoE power budget
- Easy-to-use web-based management interface
- Supports IPv6, LACP, VLAN, QoS, and IGMP Snooping
- Bandwidth control per port
- Private and Voice VLAN support
- Smart Fan
- 56Gbps switching capacity
- IEEE 802.1p QoS with queue scheduling support
Description
TRENDnet’s 28-Port Gigabit Web Smart PoE+ Switch, model TPE-5028WS, delivers advanced management features with a 56Gbps switching capacity. This rack mountable IPv6 ready switch comes with an intuitive web-based interface. Advanced traffic management controls, troubleshooting, and SNMP monitoring make this a powerful solution for SMB networks. The TPE-5028WS provides 24 gigabit PoE+ ports with a total power budget of 370W, and four shared gigabit ports (RJ-45 or SFP). The PoE+ standard supplies up to 30W of power per port for devices such as high power wireless access points, PTZ (Pan Tilt Zoom) Internet cameras, and VoIP telephony systems.Web Smart Management
Provides an easy-to-use web-based management interface to reduce switch configuration complexity and offers a combination of SMB management features for easy deployment.
Integration Flexibility
Managed features include access control lists, VLAN, IGMP snooping, QoS, RMON, SNMP trap, and syslog for monitoring and flexible network integration.
PoE Power
A 370W PoE power budget supplies power to PoE/PoE+ devices.
Hardware Design
Provides 24 gigabit PoE+ ports, 4 shared gigabit ports (RJ-45 or SFP), a 56Gbps switching capacity, a built-in power supply, and rackmount brackets.
PoE Power
Supports up to 30W of PoE+ power per port with a total power budget of 370W.
IPv6 Ready
This switch supports IPv6 configuration and IPv6 neighbor discovery.
Traffic Management
A broad range of network configurations are supported: 802.3ad link aggregation, Asymmetric VLAN, 802.1Q VLAN, Voice VLAN, RSTP, MSTP, Loopback Detection, GVRP, 802.1p Class of Service (CoS), port bandwidth management, and QoS queue scheduling.
Troubleshooting
A convenient cable diagnostic test and traffic statistics aid in network troubleshooting
Access Control
Features such as ACL, SSL, MAC/port filtering, 802.1X, TACACS+, and RADIUS are compatible with layered access controls.
Monitoring
RMON, SNMP, SNMP Trap, and Port Mirroring support administrator monitoring solutions.
Specifications
| Management features | |
|---|---|
| Switch type | Managed |
| Web-based management | Yes |
| Quality of Service (QoS) support | Yes |
| Multicast support | Yes |
| MIB support | IP FORWARD TABLE MIB RFC 1354, RMON MIB RFC 1271, IPV4 MIB RFC 1213, IPV6 MIB RFC 2465, GVRP MIB IEEE 802.1Q-VLAN, LA MIB IEEE 802.3ad, LLDP MIB IEEE 802.1AB, IGMP SNOOPING MIB RFC 2933, MLD SNOOPING MIB RFC 3019, PRIVATE VLAN MIB IEEE 802.1Q, DHCPSNOOP MIB RFC 2026, QOS MIB RFC 4323, SNMP MIB RFC 3415, STP MIB RFC 4318, PNAC MIB IEEE 802.1x, VLAN MIB IEEE 802.1q, DNS MIB RFC 1611, ACL MIB, BANDWIDTH CTRL MIB, LBD MIB, MIRROR MIB, IPV6 NEIGHBOR MIB, SNTP MIB, STORM CTRL MIB, STATISTICS MIB, Tool MIB, VOICE VLAN MIB, DOS MIB |
| Ports & interfaces | |
| Basic switching RJ-45 Ethernet ports quantity | 24 |
| Basic switching RJ-45 Ethernet ports type | Gigabit Ethernet (10/100/1000) |
| Combo SFP ports quantity | 4 |
| Power connector | DC-in jack |
| Network | |
| Networking standards | IEEE 802.1D, IEEE 802.1Q, IEEE 802.1ab, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.1x, IEEE 802.3, IEEE 802.3ab, IEEE 802.3ad, IEEE 802.3af, IEEE 802.3at, IEEE 802.3az, IEEE 802.3u, IEEE 802.3x, IEEE 802.3z |
| Full duplex | Yes |
| Head-of-line (HOL) blocking | Yes |
| VLAN support | Yes |
| Spanning tree protocol | Yes |
| Port mirroring | Yes |
| Link aggregation | Yes |
| Virtual LAN features | Private VLAN, VLAN Identifier ( VLAN ID), Voice VLAN, Tagged VLAN |
| IGMP snooping | Yes |
| Data transmission | |
| Jumbo frames | 10000 |
| Packet buffer memory | 4.1 MB |
| MAC address table | 8000 entries |
| Switching capacity | 56 Gbit/s |
| Jumbo frames support | Yes |
| Forwarding rate | 41.7 Mpps |
| Multicast MAC address table | 256 entries |
| Security | |
| Security algorithms | HTTPS, SNMP, SSL/TLS |
| MAC address filtering | Yes |
| IGMP snooping | Yes |
| Access Control List (ACL) | Yes |
| Multicast features | |
| Multicast MAC address table | 256 entries |
| Multicast support | Yes |
| Design | |
| Form factor | 1U |
| Product colour | Black |
| LED indicators | Yes |
| Housing material | Linear low-density polyethylene (LLDPE) |
| Rack mounting | Yes |
| Number of fans | 2 fan(s) |
| Certification | CE, FCC |
| Performance | |
| Noise level | 52 dB |
| Mean time between failures (MTBF) | 277.604 h |
| Compatible operating systems | Windows® 10, 8.1, 8, 7, Vista, XP, Windows® 2003/2008 Server |
| Packet buffer memory | 4.1 MB |
| Harmonized System (HS) code | 85176990 |
| Power | |
| Power consumption (max) | 446 W |
| AC input voltage | 100 - 240 V |
| AC input frequency | 50 - 60 Hz |
| Power consumption (typical) | 30 W |
| Power connector | DC-in jack |
| Power over Ethernet (PoE) | |
| Power over Ethernet plus (PoE+) ports quantity | 24 |
| Total Power over Ethernet (PoE) budget | 370 W |
| Power over Ethernet (PoE) | Yes |
| Operational conditions | |
| Operating temperature (T-T) | -5 - 50 °C |
| Operating relative humidity (H-H) | 0 - 95% |
| Virtual LAN features | |
| VLAN support | Yes |
| Virtual LAN features | Private VLAN, VLAN Identifier ( VLAN ID), Voice VLAN, Tagged VLAN |
| Weight & dimensions | |
| Width | 17.3" (440 mm) |
| Depth | 9.84" (250 mm) |
| Height | 1.73" (44 mm) |
| Weight | 8.64 lbs (3.92 kg) |
| Packaging content | |
| Rack mount kit | Yes |
| Quick start guide | Yes |
| Cables included | AC |
| Resource CD | Yes |
| Packaging data | |
| Resource CD | Yes |
| Rack mount kit | Yes |
| Quick start guide | Yes |
| Cables included | AC |
| Technical details | |
| Form factor | 1U |
| Product colour | Black |
| Noise level | 52 dB |
| Mean time between failures (MTBF) | 277.604 h |
| Housing material | Linear low-density polyethylene (LLDPE) |
| Rack mounting | Yes |
| Memory | |
| Packet buffer memory | 4.1 MB |
| Certificates | |
| Certification | CE, FCC |
| Indication | |
| LED indicators | Yes |
| System requirements | |
| Compatible operating systems | Windows® 10, 8.1, 8, 7, Vista, XP, Windows® 2003/2008 Server |
| Logistics data | |
| Harmonized System (HS) code | 85176990 |
Product Specs
24 x Gigabit PoE+ ports, 4 x Shared Gigabit ports, 370 W, 56 Gbps
Web Smart Management
Provides an easy-to-use web-based management interface to reduce switch configuration complexity and offers a combination of SMB management features for easy deployment.
Integration Flexibility
Managed features include access control lists, VLAN, IGMP snooping, QoS, RMON, SNMP trap, and syslog for monitoring and flexible network integration.
PoE Power
A 370W PoE power budget supplies power to PoE/PoE+ devices.
Hardware Design
Provides 24 gigabit PoE+ ports, 4 shared gigabit ports (RJ-45 or SFP), a 56Gbps switching capacity, a built-in power supply, and rackmount brackets.
PoE Power
Supports up to 30W of PoE+ power per port with a total power budget of 370W.
IPv6 Ready
This switch supports IPv6 configuration and IPv6 neighbor discovery.
Traffic Management
A broad range of network configurations are supported: 802.3ad link aggregation, Asymmetric VLAN, 802.1Q VLAN, Voice VLAN, RSTP, MSTP, Loopback Detection, GVRP, 802.1p Class of Service (CoS), port bandwidth management, and QoS queue scheduling.
Troubleshooting
A convenient cable diagnostic test and traffic statistics aid in network troubleshooting
Access Control
Features such as ACL, SSL, MAC/port filtering, 802.1X, TACACS+, and RADIUS are compatible with layered access controls.
Monitoring
RMON, SNMP, SNMP Trap, and Port Mirroring support administrator monitoring solutions.
Key Features
- 24 x Gigabit PoE+ ports
- 4 x Shared Gigabit ports (RJ-45 or SFP)
- 370W PoE power budget
- Easy-to-use web-based management interface
- Supports IPv6, LACP, VLAN, QoS, and IGMP Snooping
- Bandwidth control per port
- Private and Voice VLAN support
- Smart Fan
- 56Gbps switching capacity
- IEEE 802.1p QoS with queue scheduling support
Description
TRENDnet’s 28-Port Gigabit Web Smart PoE+ Switch, model TPE-5028WS, delivers advanced management features with a 56Gbps switching capacity. This rack mountable IPv6 ready switch comes with an intuitive web-based interface. Advanced traffic management controls, troubleshooting, and SNMP monitoring make this a powerful solution for SMB networks. The TPE-5028WS provides 24 gigabit PoE+ ports with a total power budget of 370W, and four shared gigabit ports (RJ-45 or SFP). The PoE+ standard supplies up to 30W of power per port for devices such as high power wireless access points, PTZ (Pan Tilt Zoom) Internet cameras, and VoIP telephony systems.Web Smart Management
Provides an easy-to-use web-based management interface to reduce switch configuration complexity and offers a combination of SMB management features for easy deployment.
Integration Flexibility
Managed features include access control lists, VLAN, IGMP snooping, QoS, RMON, SNMP trap, and syslog for monitoring and flexible network integration.
PoE Power
A 370W PoE power budget supplies power to PoE/PoE+ devices.
Hardware Design
Provides 24 gigabit PoE+ ports, 4 shared gigabit ports (RJ-45 or SFP), a 56Gbps switching capacity, a built-in power supply, and rackmount brackets.
PoE Power
Supports up to 30W of PoE+ power per port with a total power budget of 370W.
IPv6 Ready
This switch supports IPv6 configuration and IPv6 neighbor discovery.
Traffic Management
A broad range of network configurations are supported: 802.3ad link aggregation, Asymmetric VLAN, 802.1Q VLAN, Voice VLAN, RSTP, MSTP, Loopback Detection, GVRP, 802.1p Class of Service (CoS), port bandwidth management, and QoS queue scheduling.
Troubleshooting
A convenient cable diagnostic test and traffic statistics aid in network troubleshooting
Access Control
Features such as ACL, SSL, MAC/port filtering, 802.1X, TACACS+, and RADIUS are compatible with layered access controls.
Monitoring
RMON, SNMP, SNMP Trap, and Port Mirroring support administrator monitoring solutions.
Specifications
| Management features | |
|---|---|
| Switch type | Managed |
| Web-based management | Yes |
| Quality of Service (QoS) support | Yes |
| Multicast support | Yes |
| MIB support | IP FORWARD TABLE MIB RFC 1354, RMON MIB RFC 1271, IPV4 MIB RFC 1213, IPV6 MIB RFC 2465, GVRP MIB IEEE 802.1Q-VLAN, LA MIB IEEE 802.3ad, LLDP MIB IEEE 802.1AB, IGMP SNOOPING MIB RFC 2933, MLD SNOOPING MIB RFC 3019, PRIVATE VLAN MIB IEEE 802.1Q, DHCPSNOOP MIB RFC 2026, QOS MIB RFC 4323, SNMP MIB RFC 3415, STP MIB RFC 4318, PNAC MIB IEEE 802.1x, VLAN MIB IEEE 802.1q, DNS MIB RFC 1611, ACL MIB, BANDWIDTH CTRL MIB, LBD MIB, MIRROR MIB, IPV6 NEIGHBOR MIB, SNTP MIB, STORM CTRL MIB, STATISTICS MIB, Tool MIB, VOICE VLAN MIB, DOS MIB |
| Ports & interfaces | |
| Basic switching RJ-45 Ethernet ports quantity | 24 |
| Basic switching RJ-45 Ethernet ports type | Gigabit Ethernet (10/100/1000) |
| Combo SFP ports quantity | 4 |
| Power connector | DC-in jack |
| Network | |
| Networking standards | IEEE 802.1D, IEEE 802.1Q, IEEE 802.1ab, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.1x, IEEE 802.3, IEEE 802.3ab, IEEE 802.3ad, IEEE 802.3af, IEEE 802.3at, IEEE 802.3az, IEEE 802.3u, IEEE 802.3x, IEEE 802.3z |
| Full duplex | Yes |
| Head-of-line (HOL) blocking | Yes |
| VLAN support | Yes |
| Spanning tree protocol | Yes |
| Port mirroring | Yes |
| Link aggregation | Yes |
| Virtual LAN features | Private VLAN, VLAN Identifier ( VLAN ID), Voice VLAN, Tagged VLAN |
| IGMP snooping | Yes |
| Data transmission | |
| Jumbo frames | 10000 |
| Packet buffer memory | 4.1 MB |
| MAC address table | 8000 entries |
| Switching capacity | 56 Gbit/s |
| Jumbo frames support | Yes |
| Forwarding rate | 41.7 Mpps |
| Multicast MAC address table | 256 entries |
| Security | |
| Security algorithms | HTTPS, SNMP, SSL/TLS |
| MAC address filtering | Yes |
| IGMP snooping | Yes |
| Access Control List (ACL) | Yes |
| Multicast features | |
| Multicast MAC address table | 256 entries |
| Multicast support | Yes |
| Design | |
| Form factor | 1U |
| Product colour | Black |
| LED indicators | Yes |
| Housing material | Linear low-density polyethylene (LLDPE) |
| Rack mounting | Yes |
| Number of fans | 2 fan(s) |
| Certification | CE, FCC |
| Performance | |
| Noise level | 52 dB |
| Mean time between failures (MTBF) | 277.604 h |
| Compatible operating systems | Windows® 10, 8.1, 8, 7, Vista, XP, Windows® 2003/2008 Server |
| Packet buffer memory | 4.1 MB |
| Harmonized System (HS) code | 85176990 |
| Power | |
| Power consumption (max) | 446 W |
| AC input voltage | 100 - 240 V |
| AC input frequency | 50 - 60 Hz |
| Power consumption (typical) | 30 W |
| Power connector | DC-in jack |
| Power over Ethernet (PoE) | |
| Power over Ethernet plus (PoE+) ports quantity | 24 |
| Total Power over Ethernet (PoE) budget | 370 W |
| Power over Ethernet (PoE) | Yes |
| Operational conditions | |
| Operating temperature (T-T) | -5 - 50 °C |
| Operating relative humidity (H-H) | 0 - 95% |
| Virtual LAN features | |
| VLAN support | Yes |
| Virtual LAN features | Private VLAN, VLAN Identifier ( VLAN ID), Voice VLAN, Tagged VLAN |
| Weight & dimensions | |
| Width | 17.3" (440 mm) |
| Depth | 9.84" (250 mm) |
| Height | 1.73" (44 mm) |
| Weight | 8.64 lbs (3.92 kg) |
| Packaging content | |
| Rack mount kit | Yes |
| Quick start guide | Yes |
| Cables included | AC |
| Resource CD | Yes |
| Packaging data | |
| Resource CD | Yes |
| Rack mount kit | Yes |
| Quick start guide | Yes |
| Cables included | AC |
| Technical details | |
| Form factor | 1U |
| Product colour | Black |
| Noise level | 52 dB |
| Mean time between failures (MTBF) | 277.604 h |
| Housing material | Linear low-density polyethylene (LLDPE) |
| Rack mounting | Yes |
| Memory | |
| Packet buffer memory | 4.1 MB |
| Certificates | |
| Certification | CE, FCC |
| Indication | |
| LED indicators | Yes |
| System requirements | |
| Compatible operating systems | Windows® 10, 8.1, 8, 7, Vista, XP, Windows® 2003/2008 Server |
| Logistics data | |
| Harmonized System (HS) code | 85176990 |
Loading product information from Icecat...
Related products
FAQ
Questions? We're Here to Help.
Can't find what you're looking for? Our team is available through live chat.
Need immediate assistance?
Our sales engineering and accounts team is available Monday through Friday, 9:00 AM to 6:00 PM ET.
Call (315) 930-4535We offer computing hardware, networking equipment, servers and storage, plus power and security products from leading technology brands.
Yes, our team provides pre-sale consultation and post-purchase support to ensure you get the right solutions for your needs.
Return new, undamaged items with all accessories and original packaging within 30 days of delivery. A 20% restocking fee applies to non-defective returns. Defective, damaged or incorrect items are replaced or refunded, with a free return label.
Standard shipping is $25, free on orders over $2,500 in the contiguous US Express is $40, or $350 on orders over $2,500. Alaska and Hawaii ship by air for $85. In-stock orders leave the warehouse within 2-3 business days, standard transit is 5-7 business days and express 1–2 days.
Absolutely! Contact our sales team via live chat, phone, or email to discuss your requirements and receive a customized quote.
Popular Queries
LG 50UL3Q-E signage display Digital signage flat panel 50" LED Wi-Fi 350 cd/m² 4K Ultra HD Black WebOS 16/7
DELL Pro 65 Plus P6524QT Interactive flat panel 64.53" LCD 350 cd/m² 4K Ultra HD Black Touchscreen
Logitech Tap Scheduler 2 video conferencing system Ethernet LAN Video conferencing service management system
HP Poly Savi 7310-M Office Microsoft Teams Certified DECT 1920-1930 MHz Headset TAA
Juniper EX4100-24T network switch Unmanaged Power over Ethernet (PoE) 1U Gray
HP Poly CCX 600 Business Media Phone with Open SIP with Power Supply
NETGEAR GSM4352PB Managed L2/L3/L4 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) 1U Black
HPE Aruba Networking CX 6200F 24G Class-4 PoE 4SFP+ 370W Managed L3 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) 1U
Ubiquiti USW-Pro-Max-24-PoE L3 2.5G Ethernet (100/1000/2500) Power over Ethernet (PoE) Gray
HP Poly Trio C60 IP Conference Phone Full Radio and PoE-enabled GSA/TAA
HP Poly Trio C60 IP Conference Phone for Microsoft Teams and PoE-enabled No Radio GSA/TAA
AddOn Networks QSFP28-100GB-SR4-E-AR-AO network transceiver module Fiber optic 100000 Mbit/s 850 nm
Axiom Q28-100G-BIDI-DLN-AX network transceiver module Fiber optic 100000 Mbit/s QSFP28
HP Poly CCX 400 Business Media Phone for Microsoft Teams and PoE-enabled
HP Poly TC10 White Touch Controller
View all →