Phone number: (315) 930-4535
Email: sales@buyitsolutions.com
Address: 241-40 86th Rd Jamaica New York 11426 United States
EIN NUMBER: 93-2319428
D-U-N-S Number: 130972525
Skip to product information
D-Link
D-Link DSS-200G-10MPP network switch Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) 1U Black, Gray
SKU:
DSS-200G-10MPP
Condition: New
$334.22 USD
Pickup currently not available
✔
Factory-Sealed
Sourced from authorized distributors
✔
Manufacturer Warranty
Terms set by the brand
✔
Enterprise Expertise
Business Procurement
Free standard shipping over $2,500
Delivery estimates are based on product availability, destination, fulfillment method, and qualifying order requirements. 30-day returns; 20% restocking fee on non-defective returns. Shipping policy · Return policy
Loading documents...
Need Help Before You Order?
Check compatibility, availability, or volume pricing with an IT procurement specialist.
Enterprise IT Procurement Built for Business
Source servers, networking, storage, workstations, and business technology through established distribution channels with dedicated procurement support.
1,700+
Business Accounts Supported
32,000+
Enterprise Hardware Products Available
Fast, Reliable Procurement Support
Reach out for responsive product availability, part numbers, pricing, and additional hardware needs.
4–8 Hrs
Typical RFQ Response Target
Multi-Vendor
Hardware Sourcing
Keep Your IT Projects Moving
For business hardware purchases and larger deployments, get shipment information, order coordination, and delivery support.
Manufacturer Warranty Coverage
Eligible products include warranty coverage provided by the original manufacturer according to applicable brand and product terms.
Brand Warranty TermsFactory-Sealed HardwareOEM Support Eligibility
A Trusted Source for Enterprise Hardware
Source factory-sealed IT hardware through established technology distribution channels, with support for individual purchases, BOM requests, and larger business requirements.
112+
Technology Brands
32,000+
Hardware Products Available
Key Features
1U, Gigabit Ethernet, 8x 10/100/1000 Mbps PoE, 2x SFP 1000 Mbps, 14.88 Mpps, 8K Entries, PoE 242 W, DDR3 128 MB, 50.6 dB
Enhance your surveillance environment with the DSS-200G, a smart and easily installed device that delivers greater control and flexibility. Discover the capabilities of this intelligent tool that automates processes and adds intelligence to your network.
Built for Surveillance,
with Gigabit Ethernet & PoE++
Designed to meet surveillance requirements for businesses of all sizes, with features like support for high-powered PTZ cameras, high PoE budgets, Auto Surveillance VLAN, and surge protection, these switches are ideal for IP surveillance setups.
Long Range PoE Delivery
Connect and power cameras up to 250 metres away without the need for additional PoE extenders.
Power Your Devices
Supports PoE/PoE+ to connect and power your PoE-cable network devices via Ethernet cables without the need for power adapters.
Reliable PoE Connections
Surge protection on all PoE ports protects the switch when feeding power to PoE-capable devices.
Rapid deployments with a single PoE cable.
The series supports PoE, and some provide higher power PoE++, delivering up to 90 watts on selected ports, enabling faster deployment of PoE devices such as IP cameras, VoIP phones, access points, terminals, speakers, lights, conferencing systems, displays, and more.
Reach further with a flick of a switch.
The built-in DIP switch allows easy configuration and quick adjustment of application settings without the need to access the web configuration. Quickly enable and disable functions such as QoS, Extend (connection by up to 250 metres), Port Isolation, PD-Alive and STP (Spanning Tree Protocol) in an instant.
Protects the network against power surges.
6kV surge protection on all PoE ports protects the network against voltage spikes with link aggregation, ERPS and STP support to make your network more robust and resilient.
Connect to more with PoE++
See your remaining power availability with the built-in PoE Power Budget LEDs for 25%, 50%, 75%, and 100% power usage at a glance. And utilise up to 518W, with 90W on 8 ports and 30W on 15 ports for DSS-200G-28MPP, so you can rapidly deploy more devices.
Layer 2 management features.
Comes with a complete line-up of L2 features, including port mirroring, Spanning Tree Protocol (STP), and Link Aggregation Control Protocol (LACP). Network maintenance features such as loopback detection and cable diagnostics.
Quality of Service and bandwidth control.
Bandwidth control allows network administrators to reserve bandwidth for important functions that require higher priority or more bandwidth.
Auto Surveillance VLAN consolidates data and surveillance video transmission through a single switch, sparing businesses the expense of dedicated hardware and facilities.
Voice VLAN enhances the VoIP service by automatically placing voice traffic from IP phones to a designated VLAN. With a prioritised and segmented VLAN, this feature guarantees quality and security of VoIP traffic.
Energy efficient
With built-in D-Link Green technology, this series saves power without sacrificing operational performance or functionality.
Time-Based PoE
Schedule the ports on the switch to provide PoE power to devices on specific days and during set hours of the week for energy savings
Sleep mode
Link status drastically reduces power consumption by automatically putting ports without a link into a sleep mode
Advanced chipset
The series incorporates a special chipset with advanced silicon technology for efficient use of energy
We're here to help.
Over 35 years in the networking industry
Innovative end-to-end solution experts for small businesses to large corporations around the world.
Talking to us is easy
Skilled local support in 16 countries. Our support teams are ready to help you.
Key Features
- High PoE budgets and support for IEEE 802.3bt 90 W PoE
- 6 kV surge protection on all PoE ports
- Alarm Port and four-stage PoE usage indicator light
- Smart Fan design
- Surveillance traffic optimization
- Auto-detect ONVIF devices
- Built-in SNMP MIB
- Surveillance VLAN
- Easy deployment with automatic configuration
- NDAA Compliant
- D-Link Lifetime Warranty after Registration
Description
Enjoy the Power of Next-Gen Surveillance SwitchEnhance your surveillance environment with the DSS-200G, a smart and easily installed device that delivers greater control and flexibility. Discover the capabilities of this intelligent tool that automates processes and adds intelligence to your network.
Built for Surveillance,
with Gigabit Ethernet & PoE++
Designed to meet surveillance requirements for businesses of all sizes, with features like support for high-powered PTZ cameras, high PoE budgets, Auto Surveillance VLAN, and surge protection, these switches are ideal for IP surveillance setups.
Long Range PoE Delivery
Connect and power cameras up to 250 metres away without the need for additional PoE extenders.
Power Your Devices
Supports PoE/PoE+ to connect and power your PoE-cable network devices via Ethernet cables without the need for power adapters.
Reliable PoE Connections
Surge protection on all PoE ports protects the switch when feeding power to PoE-capable devices.
Rapid deployments with a single PoE cable.
The series supports PoE, and some provide higher power PoE++, delivering up to 90 watts on selected ports, enabling faster deployment of PoE devices such as IP cameras, VoIP phones, access points, terminals, speakers, lights, conferencing systems, displays, and more.
Reach further with a flick of a switch.
The built-in DIP switch allows easy configuration and quick adjustment of application settings without the need to access the web configuration. Quickly enable and disable functions such as QoS, Extend (connection by up to 250 metres), Port Isolation, PD-Alive and STP (Spanning Tree Protocol) in an instant.
Protects the network against power surges.
6kV surge protection on all PoE ports protects the network against voltage spikes with link aggregation, ERPS and STP support to make your network more robust and resilient.
Connect to more with PoE++
See your remaining power availability with the built-in PoE Power Budget LEDs for 25%, 50%, 75%, and 100% power usage at a glance. And utilise up to 518W, with 90W on 8 ports and 30W on 15 ports for DSS-200G-28MPP, so you can rapidly deploy more devices.
Layer 2 management features.
Comes with a complete line-up of L2 features, including port mirroring, Spanning Tree Protocol (STP), and Link Aggregation Control Protocol (LACP). Network maintenance features such as loopback detection and cable diagnostics.
Quality of Service and bandwidth control.
Bandwidth control allows network administrators to reserve bandwidth for important functions that require higher priority or more bandwidth.
Auto Surveillance VLAN consolidates data and surveillance video transmission through a single switch, sparing businesses the expense of dedicated hardware and facilities.
Voice VLAN enhances the VoIP service by automatically placing voice traffic from IP phones to a designated VLAN. With a prioritised and segmented VLAN, this feature guarantees quality and security of VoIP traffic.
Energy efficient
With built-in D-Link Green technology, this series saves power without sacrificing operational performance or functionality.
Time-Based PoE
Schedule the ports on the switch to provide PoE power to devices on specific days and during set hours of the week for energy savings
Sleep mode
Link status drastically reduces power consumption by automatically putting ports without a link into a sleep mode
Advanced chipset
The series incorporates a special chipset with advanced silicon technology for efficient use of energy
We're here to help.
Over 35 years in the networking industry
Innovative end-to-end solution experts for small businesses to large corporations around the world.
Talking to us is easy
Skilled local support in 16 countries. Our support teams are ready to help you.
Specifications
| Management features | |
|---|---|
| Traffic classification | Yes |
| Reset button | Yes |
| Switch type | Managed |
| Web-based management | Yes |
| Quality of Service (QoS) support | Yes |
| Multicast support | Yes |
| MIB support | • RFC768 UDP • RFC791 IP • RFC792 ICMP • RFC793 TCP • RFC826 ARP • RFC1213 MIB II • RFC1493 Bridage MIB • RFC1907 SNMPv2 MIB • RFC1215 MIB Traps Convention • RFC2233 Interface Group MIB • RFC2665 Ether-like MIB • RFC4363 IEEE 802.1p MIB • ZoneDefense MIB • Private MIB • RFC951 BootP client • RFC1542 BootP/DHCP client • RFC2236 IGMP Snooping |
| Switch layer | L2 |
| Ports & interfaces | |
| Basic switching RJ-45 Ethernet ports quantity | 10 |
| Basic switching RJ-45 Ethernet ports type | Gigabit Ethernet (10/100/1000) |
| Installed SFP modules quantity | 2 |
| Network | |
| Networking standards | IEEE 802.3, IEEE 802.3ab, IEEE 802.3ad, IEEE 802.3af, IEEE 802.3at, IEEE 802.3az, IEEE 802.3bt, IEEE 802.3u, IEEE 802.3x |
| Full duplex | Yes |
| Head-of-line (HOL) blocking | Yes |
| VLAN support | Yes |
| Spanning tree protocol | Yes |
| Rate limiting | Yes |
| Port mirroring | Yes |
| Number of VLANs | 4094 |
| Link aggregation | Yes |
| Flow control support | Yes |
| Ethernet LAN data rates | 1000 Mbit/s |
| Broadcast storm control | Yes |
| Auto MDI/MDI-X | Yes |
| Auto-negotiation | Yes |
| Half duplex | Yes |
| Virtual LAN features | Voice VLAN |
| IGMP snooping | Yes |
| Data transmission | |
| Jumbo frames | 10240 |
| Packet buffer memory | 4.1 MB |
| MAC address table | 8000 entries |
| Switching capacity | 20 Gbit/s |
| Number of queues | 4 |
| Jumbo frames support | Yes |
| Forwarding rate | 14.88 Mpps |
| Number of VLANs | 4094 |
| Security | |
| SSH/SSL support | Yes |
| IGMP snooping | Yes |
| Queue scheduling algorithms | Strict Priority Queue (SPQ), Weighted Round Robin (WRR) |
| Password protection | Yes |
| Multicast features | |
| Multicast support | Yes |
| Multicast features | Controllable multicast |
| Design | |
| Reset button | Yes |
| Form factor | 1U |
| Product colour | Black, Gray |
| LED indicators | Activity, Alarm, Link, Power, Speed |
| Rack mounting | Yes |
| Number of fans | 1 fan(s) |
| Performance | |
| Noise level | 50.6 dB |
| Memory type | DDR3-SDRAM |
| Mean time between failures (MTBF) | 508112 h |
| Internal memory | 128 MB |
| Flash memory | 32 MB |
| Fanless | No |
| Packet buffer memory | 4.1 MB |
| Auto-negotiation | Yes |
| Power | |
| Power supply included | Yes |
| AC input voltage | 100 - 240 V |
| AC input frequency | 50/60 Hz |
| Power consumption (typical) | 267.5 W |
| Input voltage | 100 - 240 V |
| Input current | 3 A |
| Power source | AC |
| Power over Ethernet (PoE) | |
| Power over Ethernet (PoE) power per port | 90 W |
| Total Power over Ethernet (PoE) budget | 242 W |
| Power over Ethernet (PoE) ports quantity | 8 |
| Power over Ethernet (PoE) | Yes |
| Operational conditions | |
| Storage temperature (T-T) | -40 - 70 °C |
| Storage relative humidity (H-H) | 0 - 95% |
| Operating temperature (T-T) | -5 - 50 °C |
| Operating relative humidity (H-H) | 0 - 95% |
| Heat dissipation | 87 BTU/h |
| Virtual LAN features | |
| VLAN support | Yes |
| Number of VLANs | 4094 |
| Virtual LAN features | Voice VLAN |
| Weight & dimensions | |
| Width | 11" (280 mm) |
| Depth | 9.06" (230 mm) |
| Height | 1.73" (44 mm) |
| Weight | 4.52 lbs (2.05 kg) |
| Sustainability | |
| Sustainability certificates | UL ECOLOGO |
| Technical details | |
| Form factor | 1U |
| Product colour | Black, Gray |
| Noise level | 50.6 dB |
| Mean time between failures (MTBF) | 508112 h |
| Rack mounting | Yes |
| Sustainability certificates | UL ECOLOGO |
| Compliance certificates | BSMI, CB, CE, Federal Communications Commission (FCC), Low Voltage Directive (LVD), cUL |
| Memory | |
| Packet buffer memory | 4.1 MB |
| Memory type | DDR3-SDRAM |
| Internal memory | 128 MB |
| Flash memory | 32 MB |
| Certificates | |
| Compliance certificates | BSMI, CB, CE, Federal Communications Commission (FCC), Low Voltage Directive (LVD), cUL |
| Indication | |
| LED indicators | Activity, Alarm, Link, Power, Speed |
| Other features | |
| Input voltage | 100 - 240 V |
| Ethernet LAN data rates | 1000 Mbit/s |
Product Specs
1U, Gigabit Ethernet, 8x 10/100/1000 Mbps PoE, 2x SFP 1000 Mbps, 14.88 Mpps, 8K Entries, PoE 242 W, DDR3 128 MB, 50.6 dB
Enhance your surveillance environment with the DSS-200G, a smart and easily installed device that delivers greater control and flexibility. Discover the capabilities of this intelligent tool that automates processes and adds intelligence to your network.
Built for Surveillance,
with Gigabit Ethernet & PoE++
Designed to meet surveillance requirements for businesses of all sizes, with features like support for high-powered PTZ cameras, high PoE budgets, Auto Surveillance VLAN, and surge protection, these switches are ideal for IP surveillance setups.
Long Range PoE Delivery
Connect and power cameras up to 250 metres away without the need for additional PoE extenders.
Power Your Devices
Supports PoE/PoE+ to connect and power your PoE-cable network devices via Ethernet cables without the need for power adapters.
Reliable PoE Connections
Surge protection on all PoE ports protects the switch when feeding power to PoE-capable devices.
Rapid deployments with a single PoE cable.
The series supports PoE, and some provide higher power PoE++, delivering up to 90 watts on selected ports, enabling faster deployment of PoE devices such as IP cameras, VoIP phones, access points, terminals, speakers, lights, conferencing systems, displays, and more.
Reach further with a flick of a switch.
The built-in DIP switch allows easy configuration and quick adjustment of application settings without the need to access the web configuration. Quickly enable and disable functions such as QoS, Extend (connection by up to 250 metres), Port Isolation, PD-Alive and STP (Spanning Tree Protocol) in an instant.
Protects the network against power surges.
6kV surge protection on all PoE ports protects the network against voltage spikes with link aggregation, ERPS and STP support to make your network more robust and resilient.
Connect to more with PoE++
See your remaining power availability with the built-in PoE Power Budget LEDs for 25%, 50%, 75%, and 100% power usage at a glance. And utilise up to 518W, with 90W on 8 ports and 30W on 15 ports for DSS-200G-28MPP, so you can rapidly deploy more devices.
Layer 2 management features.
Comes with a complete line-up of L2 features, including port mirroring, Spanning Tree Protocol (STP), and Link Aggregation Control Protocol (LACP). Network maintenance features such as loopback detection and cable diagnostics.
Quality of Service and bandwidth control.
Bandwidth control allows network administrators to reserve bandwidth for important functions that require higher priority or more bandwidth.
Auto Surveillance VLAN consolidates data and surveillance video transmission through a single switch, sparing businesses the expense of dedicated hardware and facilities.
Voice VLAN enhances the VoIP service by automatically placing voice traffic from IP phones to a designated VLAN. With a prioritised and segmented VLAN, this feature guarantees quality and security of VoIP traffic.
Energy efficient
With built-in D-Link Green technology, this series saves power without sacrificing operational performance or functionality.
Time-Based PoE
Schedule the ports on the switch to provide PoE power to devices on specific days and during set hours of the week for energy savings
Sleep mode
Link status drastically reduces power consumption by automatically putting ports without a link into a sleep mode
Advanced chipset
The series incorporates a special chipset with advanced silicon technology for efficient use of energy
We're here to help.
Over 35 years in the networking industry
Innovative end-to-end solution experts for small businesses to large corporations around the world.
Talking to us is easy
Skilled local support in 16 countries. Our support teams are ready to help you.
Key Features
- High PoE budgets and support for IEEE 802.3bt 90 W PoE
- 6 kV surge protection on all PoE ports
- Alarm Port and four-stage PoE usage indicator light
- Smart Fan design
- Surveillance traffic optimization
- Auto-detect ONVIF devices
- Built-in SNMP MIB
- Surveillance VLAN
- Easy deployment with automatic configuration
- NDAA Compliant
- D-Link Lifetime Warranty after Registration
Description
Enjoy the Power of Next-Gen Surveillance SwitchEnhance your surveillance environment with the DSS-200G, a smart and easily installed device that delivers greater control and flexibility. Discover the capabilities of this intelligent tool that automates processes and adds intelligence to your network.
Built for Surveillance,
with Gigabit Ethernet & PoE++
Designed to meet surveillance requirements for businesses of all sizes, with features like support for high-powered PTZ cameras, high PoE budgets, Auto Surveillance VLAN, and surge protection, these switches are ideal for IP surveillance setups.
Long Range PoE Delivery
Connect and power cameras up to 250 metres away without the need for additional PoE extenders.
Power Your Devices
Supports PoE/PoE+ to connect and power your PoE-cable network devices via Ethernet cables without the need for power adapters.
Reliable PoE Connections
Surge protection on all PoE ports protects the switch when feeding power to PoE-capable devices.
Rapid deployments with a single PoE cable.
The series supports PoE, and some provide higher power PoE++, delivering up to 90 watts on selected ports, enabling faster deployment of PoE devices such as IP cameras, VoIP phones, access points, terminals, speakers, lights, conferencing systems, displays, and more.
Reach further with a flick of a switch.
The built-in DIP switch allows easy configuration and quick adjustment of application settings without the need to access the web configuration. Quickly enable and disable functions such as QoS, Extend (connection by up to 250 metres), Port Isolation, PD-Alive and STP (Spanning Tree Protocol) in an instant.
Protects the network against power surges.
6kV surge protection on all PoE ports protects the network against voltage spikes with link aggregation, ERPS and STP support to make your network more robust and resilient.
Connect to more with PoE++
See your remaining power availability with the built-in PoE Power Budget LEDs for 25%, 50%, 75%, and 100% power usage at a glance. And utilise up to 518W, with 90W on 8 ports and 30W on 15 ports for DSS-200G-28MPP, so you can rapidly deploy more devices.
Layer 2 management features.
Comes with a complete line-up of L2 features, including port mirroring, Spanning Tree Protocol (STP), and Link Aggregation Control Protocol (LACP). Network maintenance features such as loopback detection and cable diagnostics.
Quality of Service and bandwidth control.
Bandwidth control allows network administrators to reserve bandwidth for important functions that require higher priority or more bandwidth.
Auto Surveillance VLAN consolidates data and surveillance video transmission through a single switch, sparing businesses the expense of dedicated hardware and facilities.
Voice VLAN enhances the VoIP service by automatically placing voice traffic from IP phones to a designated VLAN. With a prioritised and segmented VLAN, this feature guarantees quality and security of VoIP traffic.
Energy efficient
With built-in D-Link Green technology, this series saves power without sacrificing operational performance or functionality.
Time-Based PoE
Schedule the ports on the switch to provide PoE power to devices on specific days and during set hours of the week for energy savings
Sleep mode
Link status drastically reduces power consumption by automatically putting ports without a link into a sleep mode
Advanced chipset
The series incorporates a special chipset with advanced silicon technology for efficient use of energy
We're here to help.
Over 35 years in the networking industry
Innovative end-to-end solution experts for small businesses to large corporations around the world.
Talking to us is easy
Skilled local support in 16 countries. Our support teams are ready to help you.
Specifications
| Management features | |
|---|---|
| Traffic classification | Yes |
| Reset button | Yes |
| Switch type | Managed |
| Web-based management | Yes |
| Quality of Service (QoS) support | Yes |
| Multicast support | Yes |
| MIB support | • RFC768 UDP • RFC791 IP • RFC792 ICMP • RFC793 TCP • RFC826 ARP • RFC1213 MIB II • RFC1493 Bridage MIB • RFC1907 SNMPv2 MIB • RFC1215 MIB Traps Convention • RFC2233 Interface Group MIB • RFC2665 Ether-like MIB • RFC4363 IEEE 802.1p MIB • ZoneDefense MIB • Private MIB • RFC951 BootP client • RFC1542 BootP/DHCP client • RFC2236 IGMP Snooping |
| Switch layer | L2 |
| Ports & interfaces | |
| Basic switching RJ-45 Ethernet ports quantity | 10 |
| Basic switching RJ-45 Ethernet ports type | Gigabit Ethernet (10/100/1000) |
| Installed SFP modules quantity | 2 |
| Network | |
| Networking standards | IEEE 802.3, IEEE 802.3ab, IEEE 802.3ad, IEEE 802.3af, IEEE 802.3at, IEEE 802.3az, IEEE 802.3bt, IEEE 802.3u, IEEE 802.3x |
| Full duplex | Yes |
| Head-of-line (HOL) blocking | Yes |
| VLAN support | Yes |
| Spanning tree protocol | Yes |
| Rate limiting | Yes |
| Port mirroring | Yes |
| Number of VLANs | 4094 |
| Link aggregation | Yes |
| Flow control support | Yes |
| Ethernet LAN data rates | 1000 Mbit/s |
| Broadcast storm control | Yes |
| Auto MDI/MDI-X | Yes |
| Auto-negotiation | Yes |
| Half duplex | Yes |
| Virtual LAN features | Voice VLAN |
| IGMP snooping | Yes |
| Data transmission | |
| Jumbo frames | 10240 |
| Packet buffer memory | 4.1 MB |
| MAC address table | 8000 entries |
| Switching capacity | 20 Gbit/s |
| Number of queues | 4 |
| Jumbo frames support | Yes |
| Forwarding rate | 14.88 Mpps |
| Number of VLANs | 4094 |
| Security | |
| SSH/SSL support | Yes |
| IGMP snooping | Yes |
| Queue scheduling algorithms | Strict Priority Queue (SPQ), Weighted Round Robin (WRR) |
| Password protection | Yes |
| Multicast features | |
| Multicast support | Yes |
| Multicast features | Controllable multicast |
| Design | |
| Reset button | Yes |
| Form factor | 1U |
| Product colour | Black, Gray |
| LED indicators | Activity, Alarm, Link, Power, Speed |
| Rack mounting | Yes |
| Number of fans | 1 fan(s) |
| Performance | |
| Noise level | 50.6 dB |
| Memory type | DDR3-SDRAM |
| Mean time between failures (MTBF) | 508112 h |
| Internal memory | 128 MB |
| Flash memory | 32 MB |
| Fanless | No |
| Packet buffer memory | 4.1 MB |
| Auto-negotiation | Yes |
| Power | |
| Power supply included | Yes |
| AC input voltage | 100 - 240 V |
| AC input frequency | 50/60 Hz |
| Power consumption (typical) | 267.5 W |
| Input voltage | 100 - 240 V |
| Input current | 3 A |
| Power source | AC |
| Power over Ethernet (PoE) | |
| Power over Ethernet (PoE) power per port | 90 W |
| Total Power over Ethernet (PoE) budget | 242 W |
| Power over Ethernet (PoE) ports quantity | 8 |
| Power over Ethernet (PoE) | Yes |
| Operational conditions | |
| Storage temperature (T-T) | -40 - 70 °C |
| Storage relative humidity (H-H) | 0 - 95% |
| Operating temperature (T-T) | -5 - 50 °C |
| Operating relative humidity (H-H) | 0 - 95% |
| Heat dissipation | 87 BTU/h |
| Virtual LAN features | |
| VLAN support | Yes |
| Number of VLANs | 4094 |
| Virtual LAN features | Voice VLAN |
| Weight & dimensions | |
| Width | 11" (280 mm) |
| Depth | 9.06" (230 mm) |
| Height | 1.73" (44 mm) |
| Weight | 4.52 lbs (2.05 kg) |
| Sustainability | |
| Sustainability certificates | UL ECOLOGO |
| Technical details | |
| Form factor | 1U |
| Product colour | Black, Gray |
| Noise level | 50.6 dB |
| Mean time between failures (MTBF) | 508112 h |
| Rack mounting | Yes |
| Sustainability certificates | UL ECOLOGO |
| Compliance certificates | BSMI, CB, CE, Federal Communications Commission (FCC), Low Voltage Directive (LVD), cUL |
| Memory | |
| Packet buffer memory | 4.1 MB |
| Memory type | DDR3-SDRAM |
| Internal memory | 128 MB |
| Flash memory | 32 MB |
| Certificates | |
| Compliance certificates | BSMI, CB, CE, Federal Communications Commission (FCC), Low Voltage Directive (LVD), cUL |
| Indication | |
| LED indicators | Activity, Alarm, Link, Power, Speed |
| Other features | |
| Input voltage | 100 - 240 V |
| Ethernet LAN data rates | 1000 Mbit/s |
Loading product information from Icecat...
Related products
FAQ
Questions? We're Here to Help.
Can't find what you're looking for? Our team is available through live chat.
Need immediate assistance?
Our sales engineering and accounts team is available Monday through Friday, 9:00 AM to 6:00 PM ET.
Call (315) 930-4535We offer computing hardware, networking equipment, servers and storage, plus power and security products from leading technology brands.
Yes, our team provides pre-sale consultation and post-purchase support to ensure you get the right solutions for your needs.
Return new, undamaged items with all accessories and original packaging within 30 days of delivery. A 20% restocking fee applies to non-defective returns. Defective, damaged or incorrect items are replaced or refunded, with a free return label.
Standard shipping is $25, free on orders over $2,500 in the contiguous US Express is $40, or $350 on orders over $2,500. Alaska and Hawaii ship by air for $85. In-stock orders leave the warehouse within 2-3 business days, standard transit is 5-7 business days and express 1–2 days.
Absolutely! Contact our sales team via live chat, phone, or email to discuss your requirements and receive a customized quote.
Popular Queries
LG 50UL3Q-E signage display Digital signage flat panel 50" LED Wi-Fi 350 cd/m² 4K Ultra HD Black WebOS 16/7
DELL Pro 65 Plus P6524QT Interactive flat panel 64.53" LCD 350 cd/m² 4K Ultra HD Black Touchscreen
LG 65UL3Q-E signage display Digital signage flat panel 65" LED Wi-Fi 350 cd/m² 4K Ultra HD Black WebOS 16/7
APC Replacement Battery Cartridge, VRLA battery, 10Ah, 48VDC, 2-year warranty
Lind Electronics GE1950I-4157 power adapter/inverter Auto Black
Logitech Tap Scheduler 2 video conferencing system Ethernet LAN Video conferencing service management system
HP Poly Savi 7310-M Office Microsoft Teams Certified DECT 1920-1930 MHz Headset TAA
Juniper EX4100-24T network switch Unmanaged Power over Ethernet (PoE) 1U Gray
NETGEAR GSM4352PB Managed L2/L3/L4 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) 1U Black
HPE Aruba Networking CX 6200F 24G Class-4 PoE 4SFP+ 370W Managed L3 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) 1U
Ubiquiti USW-Pro-Max-24-PoE L3 2.5G Ethernet (100/1000/2500) Power over Ethernet (PoE) Gray
HP Poly Trio C60 IP Conference Phone Full Radio and PoE-enabled GSA/TAA
AddOn Networks QSFP28-100GB-SR4-E-AR-AO network transceiver module Fiber optic 100000 Mbit/s 850 nm
Axiom Q28-100G-BIDI-DLN-AX network transceiver module Fiber optic 100000 Mbit/s QSFP28
HP Poly TC10 White Touch Controller
View all →